Help - Search - Members - Calendar
Full Version: Boot Problems On Various Bios:es
The CD Forum > CD Shell and Boot Scriptor > Troubleshooting & Problems
milkyt
Im trying to build a couple of rescue cds for use at my work and have successfully done so.
My first boot-cd used isolinux/memdisk for approx ~15 images and was almost perfect.
The problem is that it won't boot on several machines, most notably laptops and some intel motherboards and other stray boards (some servers etc..).
I have tried _all_ mkisofs flags up and down. Rebuilt the isos in multiple versions etc.. I have tried the isolinux from the latest isolinux build.. not so latest isolinux-build, slackware-current, and finally knoppix. The strange part is that both knoppix and slackware-current does boot on all machines when i build the images.. But when I use the _SAME_ loader with the _SAME_ mkisofs buildcommand.. my iso wont boot..
Finally i gave up on isolinux, attributing it to some --boot-load-size blaha error since isolinux is bigger than 4 blocks..
So i started with a new boot-cd with cdshell.. Latest revision.
Sat up all night long and rebuilt it with timeouts, multiple keypresses etc.
But when i tried it this morning on an Acer laptop.. the DAMN THING WOULDNT BOOT!
No errormsgs no nothing, just like the older isolinux boot-cd.. just keeps dropping to
the next available bootdevice. ie. windows on a hd in this case.
But when I try a different boot-cd.. like UBCD.. It starts just fine on the same laptop.
Please help me guys. Im going nuts.. What am I missing?
Can the burning software be an issue? I have almost exclusively used nero @ work.
What am I missing? Do I need to edit some file and do some other hex-magic?

milkyn@voodoomaster:~$ mkisofs --version
mkisofs 2.01 (i686-pc-linux-gnu)

#!/bin/bash
mkisofs -o ../cofv07.iso -b boot/loader.bin -no-emul-boot -boot-load-size 4 .

mkisofs 2.01 (i686-pc-linux-gnu)
Scanning .
Scanning ./boot
Scanning ./boot/menus
Scanning ./boot/modules
Scanning ./boot/modules/isolinux
Scanning ./images
24 234
25 326 boot
26 334 menus
27 518 modules
28 160 isolinux
29 926 images
Cache hit for '/..'
30 30 /TRANS.TBL
31 31 ./mkisofs
Cache hit for 'boot/.'
Cache hit for 'boot/..'
32 39 ./boot/cdsh.bin
40 40 ./boot/cdshell.ini
41 47 ./boot/cdshw.com
48 48 ./boot/loader.bin
Cache hit for 'menus/.'
Cache hit for 'menus/..'
49 50 ./boot/menus/hdd.scn
51 52 ./boot/menus/main.scn
53 54 ./boot/menus/main2.scn
55 56 ./boot/menus/memdiag.scn
57 58 ./boot/menus/other.scn
59 59 ./boot/menus/timeout.scn
Cache hit for 'modules/.'
Cache hit for 'modules/..'
60 66 ./boot/modules/basic.csm
67 68 ./boot/modules/boot.csm
69 70 ./boot/modules/diskemu.csm
71 71 ./boot/modules/extend.csm
72 72 ./boot/modules/history.csm
73 78 ./boot/modules/isolinux.csm
79 80 ./boot/modules/macro.csm
81 81 ./boot/modules/mouse.csm
82 83 ./boot/modules/script.csm
Cache hit for 'isolinux/.'
Cache hit for 'isolinux/..'
84 84 ./boot/modules/isolinux/isolinux.cfg
85 94 ./boot/modules/isolinux/memdisk
Cache hit for 'images/.'
Cache hit for 'images/..'
95 391 ./images/aida.igz
392 859 ./images/cpuburn.igz
860 1557 ./images/dban.igz
1558 1986 ./images/dft.igz
1987 2140 ./images/fjdt.igz
2141 2712 ./images/ghost.igz
2713 2983 ./images/maxtor.igz
2984 3003 ./images/memtest.igz
3004 3025 ./images/memtestp.igz
3026 3130 ./images/mhdd.igz
3131 3799 ./images/ntrecov.igz
3800 3934 ./images/part.igz
3935 4441 ./images/pqmagic.igz
4442 4692 ./images/samsung.igz
4693 5268 ./images/sea.igz
5269 6050 ./images/seae.igz
6051 6162 ./images/spinrite.igz
6163 6392 ./images/testdisk.igz
6393 7028 ./images/wddiag.igz
Writing: Initial Padblock Start Block 0
Done with: Initial Padblock Block(s) 16
Writing: Primary Volume Descriptor Start Block 16
Done with: Primary Volume Descriptor Block(s) 1
Writing: Eltorito Volume Descriptor Start Block 17
Size of boot image is 4 sectors -> No emulation
Done with: Eltorito Volume Descriptor Block(s) 1
Writing: End Volume Descriptor Start Block 18
Done with: End Volume Descriptor Block(s) 1
Writing: Version block Start Block 19
Done with: Version block Block(s) 1
Writing: Path table Start Block 20
Done with: Path table Block(s) 4
Writing: Directory tree Start Block 24
Done with: Directory tree Block(s) 6
Writing: Directory tree cleanup Start Block 30
Done with: Directory tree cleanup Block(s) 0
Writing: The File(s) Start Block 30
Total extents scheduled to be written = 7179
69.83% done, estimate finish Thu May 26 19:30:01 2005
Total translation table size: 2048
Total rockridge attributes bytes: 0
Total directory bytes: 10240
Path table size(bytes): 82
Done with: The File(s) Block(s) 6999
Writing: Ending Padblock Start Block 7029
Done with: Ending Padblock Block(s) 150
Max brk space used 0
7179 extents written (14 MB)
milkyt
Im just gonna build the image using ultraiso.. and then let you know.
Strange part is that the mkisofs iso that i created didnt have the load segment set in the eltorito header.. but neither did UBCD..
Using "generate bootinfotable" in ultraiso made isos that wouldnt boot on my wmware workstation.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.