Help - Search - Members - Calendar
Full Version: CDShell V2.0.16 boot problems
The CD Forum > CD Shell and Boot Scriptor > Troubleshooting & Problems
Victor Chew
We have received reports of UBCD V3.3 (which is based on CDShell V2.0.16) not booting on certain machines. The error message is:

"Error booting from CD/DVD drive. Press any key to reboot"
followed by "[", 16 rectangular blocks, a large number of
periods, "]" and 80800279

The error reports can be found at:
http://www.ultimatebootcd.com/forums/viewtopic.php?p=476
http://www.ultimatebootcd.com/forums/viewtopic.php?t=142

We have tried some proposed solutions (such as re-saving the ISO image using UltraISO, or dropping some non ISO-compliant switches in mkisofs) but to no avail.

The problem seems to be specific to CDShell 2.0.16, and can be isolated down to loader.bin. CDShell 2.0.11 (which an older version of UBCD is based on) has been tested to work correctly on all machines, according to the reports.

Any suggestions on how to proceed? I think we have some really helpful users who are willing to help isolate and resolve the issue, all we need now are some directions.
zeko
according to mike (the author of cdshell) it is a hardware error:
808----- Error reading from the CD drive
Victor Chew
I really don't think this is a CDR/W or drive issue. If you re-read the messages, our users have been extremely meticulous in eliminating both media or drive factors for this problem.

Any idea what the "00279" after "808" means?
zeko
QUOTE (Victor Chew @ Jun 14 2005, 06:17 AM)
Any idea what the "00279" after "808" means?
*

i'd like to know that as well.
jmblack
The problem stems from both certain CD/CDR firmware and IDE Chipsets. When encountering this error on PCs I first attempt to replace the CDROM drive (as a diagnostic step). If that doesnt get it booting then I usually grab a CD that uses an older version of CDShell (from 2004) or use a boot CD that just uses ISOLINUX (without any cdshell). I have done experiments and when replacing the CDrom does not work, using the original CDrom, if I replace the motherboard with a different model (usually years newer) it works fine. I'd *love* to have a copy of cdshell that had more diagnostic information displayed. When it fails having something other than the error code to go by would be nice.
gvsl
Hello,
I have a solution to this problem.
Put a text file who has a maximum size of 413bytes into the root of the cd. It must be the first file on the cd ( alphabeticaly).
Example: if you let autorun.inf ( 110bytes) from the xp kit into the root of the cd( must be the first file), cdshell will work perfectly. My cd has run on many computer configurations without any problems.

How knows programming maybe can use the next informations to see where is the problem.
My cd contents WindowsXP and warez's Boot CD.


My cd root file list :

23.08.2001 11:00 2.048 PRO1.DAT
23.08.2001 11:00 2.048 PRO2.DAT
23.08.2001 11:00 2.048 PRO3.DAT
23.08.2001 11:00 2.048 PRO4.DAT
23.08.2001 11:00 2.048 PRO5.DAT
23.08.2001 11:00 2.048 PRO6.DAT
23.08.2001 11:00 2.048 PRO7.DAT
23.08.2001 11:00 34.301 README.HTM
23.08.2001 11:00 13.666 README.TXT
23.08.2001 11:00 85.792 SETUPXP.HTM
23.08.2001 11:00 11.387 SPNOTES.HTM
23.08.2001 11:00 10 WIN51
23.08.2001 11:00 10 WIN51IP
23.08.2001 11:00 2 WIN51IP.SP1
23.08.2001 11:00 2 WIN51IP.SP2


Before I found this solution I have a file named BOOTCD.TXT( from warez's BOOT CD 8.4) into cd root.
It has 14.6KB and it was the first file on the cd.
After I located the problem( try and error method) I removed BOOTCD.TXT file from root and my cd start working.
I renamed BOOTCD.TXT file into PRO0.DAT and lower it's size to 2KB( I delete characters from it) like it was a boot file( I didn't use this file in cdshell.ini). With this file, cd didn't boot.
I create a new boot file, named PRO0.DAT( like PRO1,...,PRO7;I didn't use this file in cdshell.ini). With this file, cd did boot.
After that I try to lower the file size. When the file size was 413bytes or lower the cd worked fine. When it was >=414Bytes the error "Error booting from CD/DVD drive..." appeared.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.