Help - Search - Members - Calendar
Full Version: penetcfg autostart static
The CD Forum > CD Shell and Boot Scriptor > Troubleshooting & Problems
Biedubbeljoe
Hi,

I have penetcfg as a plugin dir.

autorun0penetcfg.cmd and autorun-penetcfg.inf are in that dir and enabled.
within penetcfg_nu2menu.xml I use:

<MITEM TYPE="ITEM" DISABLED="@Or(@Not(@FileExists(@GetWinDir()\setupldr.bin)), @Not(@FileExists(@GetWinDir()\system32\penetcfg.exe)))" CMD="RUN" FUNC="@GetWinDir()\system32\penetcfg.exe /penetcfg-static">PE Network Configurator</MITEM>

so static is enabled in my opinion.

-----------------------------
within penetcfg-static.ini:
[NetAdapter1]
EnableDHCP=No
UseStaticGateway=Yes
UseStaticDNS=Yes
UseStaticWINS=Yes
IPAddress=192.168.21.50
SubnetMask=255.255.255.0

[NetID]
Workgroup=jupiter
-----------------------------

Still as BartPE boot up I get the question if I want network support now, and I run autorun network (as I believe..smile.gif
And on default he gives me DHCP and the wrong workgroup, I see at default workgroup.
How can I change it to load my settings on default as in the ini file and not ask me if I want network support..???

Thanks for the support. dry.gif
Biedubbeljoe
QUOTE (Biedubbeljoe @ Aug 18 2005, 03:44 PM)
Hi,

I have penetcfg as a plugin dir.

autorun0penetcfg.cmd and autorun-penetcfg.inf are in that dir and enabled.
within penetcfg_nu2menu.xml I use:

<MITEM TYPE="ITEM" DISABLED="@Or(@Not(@FileExists(@GetWinDir()\setupldr.bin)), @Not(@FileExists(@GetWinDir()\system32\penetcfg.exe)))" CMD="RUN" FUNC="@GetWinDir()\system32\penetcfg.exe /penetcfg-static">PE Network Configurator</MITEM>

so static is enabled in my opinion.

-----------------------------
within penetcfg-static.ini:
[NetAdapter1]
EnableDHCP=No
UseStaticGateway=Yes
UseStaticDNS=Yes
UseStaticWINS=Yes
IPAddress=192.168.21.50
SubnetMask=255.255.255.0

[NetID]
Workgroup=jupiter
-----------------------------

Still as BartPE boot up I get the question if I want network support now, and I run autorun network (as I believe..smile.gif
And on default he gives me DHCP and the wrong workgroup, I see at default workgroup.
How can I change it to load my settings on default as in the ini file and not ask me if I want network support..???

Thanks for the support. dry.gif
*


Is there nobody who can help me??
Is there nobody who can point me at my error what I am doing wrong?
I 'only' like to have the settings for a static IP address, so everything goes automatic at bootup..
mamema
QUOTE (Biedubbeljoe @ Aug 22 2005, 05:40 AM)
Is there nobody who can help me??
Is there nobody who can point me at my error what I am doing wrong?
I 'only' like to have the settings for a static IP address, so everything goes automatic at bootup..
*



look into penetcfg.ini

and change

[General]
AutoStartNet=No
PromptForProfile=Yes
ShowGUI=No

to

[General]
AutoStartNet=Yes
PromptForProfile=No
ShowGUI=No

"AutostartNet" does the trick

Best regards

mamema
Biedubbeljoe
QUOTE (mamema @ Aug 22 2005, 09:09 AM)
look into penetcfg.ini

and change

[General]
AutoStartNet=No
PromptForProfile=Yes
ShowGUI=No

to

[General]
AutoStartNet=Yes
PromptForProfile=No
ShowGUI=No

"AutostartNet" does the trick

Best regards

mamema
*


Sorry, but I already have those settings.
My penetcfg.ini looks like this:

[General]
AutoStartNet=Yes
PromptForProfile=No
ShowGUI=No

[NetProfiles]
Static IP Address (Manual)= penetcfg-static.ini

; You will get the settings below if you hit
; escape/cancel on the profile dialog
[NetAdapter1]
EnableDHCP=No
UseStaticGateway=Yes
UseStaticDNS=Yes
UseStaticWINS=Yes
IPAddress=192.168.21.50
SubnetMask=255.255.255.0

On some strange reason, penetcfg will not start (default) with the settings from penetcfg-static.ini
Any other suggestion?
Biedubbeljoe
QUOTE (Biedubbeljoe @ Aug 22 2005, 09:47 AM)
Sorry, but I already have those settings.
My penetcfg.ini looks like this:

[General]
AutoStartNet=Yes
PromptForProfile=No
ShowGUI=No

[NetProfiles]
Static IP Address (Manual)= penetcfg-static.ini

; You will get the settings below if you hit
; escape/cancel on the profile dialog
[NetAdapter1]
EnableDHCP=No
UseStaticGateway=Yes
UseStaticDNS=Yes
UseStaticWINS=Yes
IPAddress=192.168.21.50
SubnetMask=255.255.255.0

On some strange reason, penetcfg will not start (default) with the settings from penetcfg-static.ini
Any other suggestion?
*


I found the answer..
PENetCfg [/UseProfile:[profile_name]]
I replaced the UseProfile with the profilename, how green can I be..

Thanks for pointing in the right direction.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.