Help - Search - Members - Calendar
Full Version: Common Factory.exe error re: WINBOM
The CD Forum > CD Shell and Boot Scriptor > Troubleshooting & Problems
Bandito
Ok, this is driving me crazy and it really shouldn't.

I'm fortunate enough to have a copy of Winternals ERD Commander at work and had wanted to incorporate it into a handy AIO CD that I use. I walk through creating an ISO image through the Administrator's pack and incorporate the drivers to a bunch of different NIC's that I use on my workstations (including VMWare for testing). This works PERFECTLY. The ISO works flawlessly in vmware and the burned cd image works on all my PC's (registering the NIC and obtaining an IP address).

However, when I incorporate that onto a cd and use CDSHELL (& BCDW) I get the common Factory.exe error:
CODE
Failed to install network adapter - check WINBOM


I don't get it. I'm trying to keep it basic and this (at the moment) is the ONLY thing that CDSHELL is launching. I've left teh i386 directory "as is" (instead of renaming it to something like ERDC like I would like to), yet only when I use CDSHELL does this message come up.

I'm using cdshell 2.1.06 and ERD Commander 2005. ERDC Launches just fine, just doesn't install any of the network adapters. The same exact directory structure is on the ERD CD (and ISO) generated from the Admin Pack. The INF subdirectory is identical and contains all the netcard info.

In searching this forum, the one result I got led me to the following information:

QUOTE (ZULU NINER @ Apr 1 2004, 07:13 PM)
I can confirm that ERD Commander 2003 (v4.1) does work with CD Shell.  This is what I did:

1.  Copy the contents of the ERD Commander's \I386 folder into a 4 character folder of my naming choice (I used \ERDC).
2.  Copied "BOOTSEC.BIN" into the \ERDC folder.
3.  Hexedit "BOOTSEC.BIN" and "SETUPLDR.BIN", search & replace "I386" with "ERDC" (one file had 1 entry, the other file had 3 (or maybe 4)).
4.  Put the "License.txt", "Winbom.ini" & "WIN51*" files in the Root directory.
5.  Edited cdshell.ini to chain \erdc\bootsec.bin and burned my CD.

Worked like a charm for me...
*


Now I had followed this. In fact I was quite familar with editing the BIN files (but stayed away from doing so in this example). I also moved the bootsect.bin into the i386 directory. The fact remains that the only difference between the standard "out of the box" generated ERD Commander 2005 image I have that works and the one that I have that doesn't is the inclusion of CDSHELL.

Again, ERD Commander does launch and appears to work well otherwise, it's just the Network Adapters that don't register properly.

For what it's worth, I created the ERDC using Windows XP SP2. The Factory.exe is version 5.2.3790.0.

Help !?!?

Thanks,
Bandito
Ok, I think I got it.

I have to give credit to the following link at MSFN.com though...

http://www.msfn.org/board/lofiversion/index.php/t17418.html


The one thing that did jump out at me is that I've been using UltraISO to extract/create/burn my ISO images. While it's not reported to have as much trouble as WinISO, I figured let me take that out of the loop.

To get it all working I did the following:

1. I took my ERD2005.ISO image (that I created from the Admin Pack w/ network drivers included) and extracted everything to a directory using WinRAR.
2. Into that directory I copied my BCDW and BOOT directories
3. I changed my i386 directory from ERD to ERDC and updated the setupldr.bin accordingly (using a hex editor) to reference the ERDC directory.
4. I removed winbom.ini and bootsect.ini from the root of the directory structure (as they are not needed (BCDW FAQ #6)
5. I downloaded and used CDIMAGE_GUI (CD Image GUI) to create the ISO image leaving most of the default options. Since I'm using CDSHELL, pointed the boot file to loader.bin in the BOOT directory.
**NOTE: I did not "optimize" the CD since I have multiple copies of setupldr.bin with different configurations within.


That was it. Now I mounted that cd image in VMWare and booted up. My personalized cdshell splash screen appeared, I selected my ERD Commander option from my menu and it booted.... AND NO WINBOM ERRORS. Networking now works.

WOO HOO!!

Apparently the root cause was that UltraISO must have missed something or changed something when extracting the files from the original ISO image (hidden file? truncated filename? whatever). By extracting with Winrar and using CDIMAGE to rebuild the ISO all worked well.

I'll keep playing w/ editing the ISO w/ UltraISO too.... but at least I hve a way to get it all working when done.

Hope this helps someone else....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.