Help - Search - Members - Calendar
Full Version: Which Version Of Setupldr.bin Works?
The CD Forum > CD Shell and Boot Scriptor > Troubleshooting & Problems
brettster
I have tried various versions of setupldr.bin but I always get the error message
Error: File cannot be larger than 64kb.

I am using a version of winpe I created with sp2.
I am using 2.1.3 version of cdshell.

Previously I was using bcdw which worked fine, but does not work with 2.1.3 or SP2.

Can someone tell me the date/time and file size of the setupldr.bin I should be using.

Thanks
d4vr0s
You need to use the cd bootsector which calls setupldr.bin.
brettster
I assume thats bootsect.bin - 21/03/2002 8:28PM.
When I chain bootsect.bin I get CDBOOT: Couln't find NTLDR
even if I put this in the root ot I386 directory.

Sorry to be a pain. Just can't figure this out. Must be simple though. Appreciate help.
d4vr0s
You need to use the bootsector from an xp cd (in case I wasn't clear). You need to use the setupldr.bin from whatever version of windows you're trying to boot.
This is assuming you're using \i386 for your sp2 build. If not, then you need to modify both the bootsector and the setupldr.bin to point to the correct directory.
If there is a bootfix.bin in that directory AND it's not the one you're using for the initial cd bootup - you might want to remove it too as all it does is cause 'press any key to boot from cd'
Or you can use the nt5boot.bin that is mentioned here: http://www.911cd.net/forums/index.php?showtopic=8078
the site that's being referenced is here: http://bootcd.narod.ru/ntbootcd_e.htm
I hope this helps smile.gif
Zharif
There´s a real simple solution
posted by Troglodyte and some others.
Look here:
http://www.911cd.net/forums/index.php?showtopic=7888

Zharif
brettster
Thanks for your posts, I FINALLY found my problem. I was not using the -N option when creating the CD with MKISOFS. This is explained here

Dont you hate simple problems that stump you. mad.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.